mybatis/spring-boot-starter
 Watch    221
 Star    4.0k
 Fork    1.8k

MyBatis integration with Spring Boot

Java CI Coverage Status Maven central Sonatype Nexus (Snapshots) License

mybatis-spring

MyBatis Spring-Boot-Starter will help you to use MyBatis with Spring Boot

Requirements

  • master : MyBatis 3.5, MyBatis-Spring 3.0, Java 17+ and Spring Boot 3.0-3.2
  • 2.3.x : MyBatis 3.5, MyBatis-Spring 2.1, Java 8+ and Spring Boot 2.7

Compatibility Check

  • Compatibility with Spring Boot 2.6 - 3.2 here

Creating new project via Spring Initializr

Essentials

Published documentations

Snapshot documentations

Translations:

Quick Start

Quick Start for building native image

Bug report & Feature request

Question

关于
MyBatis integration with Spring Boot
最后更新于  1 days ago